Nixos installer doesn't recognize drives


I’m having troubles with two version of the graphical installer, booting from an usb drive. They don’t recognize my nvme drive.

  1. I’ve tried recent 23.05 calamares gnome installer - the installer doesn’t recognize the drive (but it sees a different sda1 ssd drive). There’s similar problem reported here. fdisk -l correctly lists the drive though.

  2. I’ve tried 22.11 kde installer (*) and again the installer doesn’t see the drive (this time it doesn’t see any drive - but it might be because I might have corrupted the sda drive in the meantime - it’s a rough day). fdisk -l lists the drives.

(*) - I had even more fun here, as the installer wouldn’t boot, because of this issue. So the actual installer I’ve tried is such a modified one: pastebin.nix.

So here I am a bit lost. Maybe there’s a problem with my drive, how would I detect it? I can correctly mount the partitions of the drive (not the drive itself - that’s expected is it?).
If the problem is in the nix installer, where can I regress to install an older one? When was calamares introduces and what was before?

My best hope right now is to install it with some other method: I’ve heard about nix-ops, nixos-up and nix-rebuild itself. Which one should I go for? Assuming I can partition with say gparted. And how would I know that I’m not risking the same issue?