Nixos-rebuild complaining about systemd-boot not installed

I just installed nixos on a new computer and I’m stuck trying to rebuild-switch on my standard configuration.
The nixos-rebuild switch command complains about “systemd-boot not installed in ESP”.

I actually have a bootloader installed (obviously as I can boot). My boot partition is mounted and seems populated as intended.
I didn’t change anything on my configuration that worked as intended about 2 days ago on another computer (exact same model).

I’m quite stuck, I don’t know where to search. I saw this post and tried everything that was proposed here.

Here are some raw informations on my system and configuration:

Thanks for any help,

What’s in /boot/EFI/systemd, or in /boot/efi/EFI/systemd, as your configuration seems to set up? Is /boot - or /boot/efi - mounted when you run this?

Is there a particular reason you change efiSysMountPoint? I would not be surprised if there’s a mistake in a script somewhere that stumbles over that.

1 Like

Oh damn, that was as simple as that…
I just removed the efiSysMountPoint from the configuration.nix and this fixed the issue.

I can’t remember why I added that line, maybe it’s just something I copy/pasted from the net and forgot about…

Thank’s for the help !