Nixos rebuild switch causing kde black screen

So after a recent sudo nix-channel --update and sudo nixos-rebuild switch kde is going black screen.

So after I login through sddm, I see my wall paper, then black flashes, then my wallpaper with no menu then black screen and a mouse pointer. I can use my shortcut keys to launch apps, but nothing else.

I have tried clearing my ~/.cache and another instruction on clearind an sddm qml cache or something that I found. Neither seems to be solving the problem, only a roll back gets me back to a useful KDE. Did I miss some news and/or am I the only one seeing this?


Answered on IRC

A quick translated overview of the discussion:

This is a case of #24256, mismatched Qt plugins.
Qt-dependent applications were installed in root’s profile.

For anyone else facing the same issue:

See if nix-env -q or sudo nix-env -q lists applications, and if any uses Qt. If they do, remove them from the environment (using nix-env -e ...) and try booting in the new generation again. Another alternative is to update the profile (nix-env -u), but this may break previous generations in the same way this breaks the new one.

Prefer installing all graphical applications using system configuration (/etc/nixos/configuration.nix) rather than nix-env, and if one only wants to test an application, one can use e.g. nix-shell -p vlc to ensure they are not added to the profiles.

OK so I saw that and said to myself hey I do a nix-env -u as part of my process so that should not be it.

The issue is I use several musician software items I don’t like in my base config so I am fixed, and thank you but I did a slight alternative to this.

Instead of moving the offending software to the base config I ran:

nix-env -u --always

So it forced the rebuild of everything.

Thank you again.