Nixos thinks boot partition is the wrong size


I have resized my boot partition but Nixos does not recognise the new size properly.

To do this I: (1) used disk tool on Debian live usb to delete Windows MSR partition. Then resized my boot partition. The disk tool gave me an error and said it couldn’t resize, but it worked anyway. Then (2) After discovering that Windows no longer booted (oh well) I decided to delete the Win partition in the same way. I then resized boot partition to 1GB, and got the same error. But it resized anyway.

Trouble is, now Nixos is mixed up on how big my boot partition is. Some commands (e.g. ‘df -h’ and also the disk utility) think it’s 96mb (discs thinks it’s 96% full for some reason). Others - e.g. ‘lsblk’ get the right size.

Any idea what’s going on, and how I can get NIxos to recognise the new size of the partition properly?

It sounds like the partition was grown, but the file system stored on that partition wasn’t updated to include the new space.

Interesting. Do you have any idea how I can update it?
One thing that occurred to me was that I didn’t erase the Win partition - I simply deleted and resized. So, maybe that has something to do with it?

That’s probably not relevant. Whatever tool you used probably just doesn’t know how to resize a vfat file system, so all it did was make the partition bigger.

Looks like you need to use the fatresize command to grow a vfat file system to fill its partition. I’m not familiar with its usage so look at its documentation to see how to use it.

The fat resizer didn’t work. Kept throwing messages about not being able to change to that particular size. Tried different sizes and then decided to nuke my entire drive. I’d been pondering this for a while so am now running 100/% Nixos with a proper sized EFI partition instead of that piddly thing the OEM stuck on. This is certainly one way to solve the problem.