No internet in Unityhub

Hello everyone, newbie here, sorry if the problem is obvious, any help would be appreciated.

I just installed NixOS a few days ago and i am loving it! There is one single problem that I couldn’t figure out. I am a UnityHub user and it installed correctly, i was able to lo in, but every time i would want to install ANY editor it just says the following: “The Hub is unable to load Editor versions. Please check your Internet connection.” Meanwhile i have perfectly good internet connection.
I already tried the following:

  • I reinstalled the complete system and applied the same config file afterwards, it changed nothing
  • I installed UnityHub from flatpak, same result
  • I installed the hub from the unstable channel

A week or so ago I installed a complete NixOS system on a SD card, to help someone. She needed UnityHub too. It worked like a charm without any problems.

Now I am 100% confused what I messed up, or if its a problem outside of my system.
Any help would be appreciated, if there is any info you need i can provide. I just didn’t want to make this post completely cluttered with unnecessary infos.

EDIT: I FINALLY got it working, although its less then ideal. I installed the 2.3.2 version (the latest stable is 3.4.2) from here:

If anyone know why it wasn’t working in the first place, please share it so I can try and use the newer version.