No sound on 19.09

I can’t get sound working on 19.09. Seems to be due to 6e886fe. For now I’ve reverted to 19.03, and sound is working perfectly fine.

Unfortunately my crystal ball is currently broken so my soothsaying powers have faded.

Why do you think that commit is related? Have you tried reverting it? How are we supposed to help you with this little information you give us? We don’t know which sound card you’re using (bluetooth?), whether you’re using pulseaudio or not and if there’s something related in the system logs.

1 Like

My audio device is Intel Corporation Cannon Lake PCH cAVS. Running lspci detects it. However, alsamixer only shows a dummy output device. It doesn’t detect my pc speaker either. I’m using pulse audio without bluetooth. Just the standard audio configuration.

  sound.enable = true;
  hardware.pulseaudio.enable = true;

Additionally, my user was added to audio group.

I don’t think it’s an issue with my hardware, since everything works fine on 19.03. I came across this thread, which led me to PR 62895. My issue seems to be related to this?

I’ll need to reinstall 19.09 to get the logs again. Is there a specific command I should use to fetch logs, or will journalctl --system suffice?

How do I revert the commit and test it on my machine? Aeschylus suggested using an overlay. Could I use an overlay to revert the commit? Will that work with /etc/nixos/configuration.nix.

The problem with using an overlay is that it might trigger mass rebuilds (on everything that depends on Alsalib),

Well, I don’t know what happened. I installed nixos-19.09 and everything just works now. Additionally, I have a webcam that wasn’t working on nixos-19.09 and nixos-19.03, and even that works now? It’s a mystery :man_shrugging: