No sound on Speaker or HDMI on Dell Latitude E5620

Hi all,

I just decided to install NixOs as my primary Os on my old Dell Latitude E5620 Laptop, but I got trouble to get sound working properly.

It only work with headset. They are always displayed as “connected” in pavucontrol even if they are not.

What works ?

Sounds output on headset plug via jack (didn’t try Bluetooth headset).

What doesn’t work ?

Sound output on speaker and on HDMI.

NixOs version


**Have I tried on another OS ? **

Yes, it way working on Xubuntu 18.04 (both speaker and HDMI)

I read a lot of post on internet about the same issue (for example this one : but didn’t find a solution.

grep Codec /proc/asound/card0/codec*
Gave me that :
Codec: IDT 92HD90BXX

I can’t find this model on

I tried several options for alsa config like :

boot.extraModprobeConfig = ''
  options snd slots=snd-hda-intel

or :

boot.extraModprobeConfig = ''
    options snd-hda-intel model=dell-s14 enable=1

But with no luck…

In alsamixer, the first card that appears is “PipeWire”, I can select “HDA Intel PCH” and see that Speaker volume is at “0”, if I set it to 70 for example, I still have no sound.

In pavucontrol headset is displayed as “connected” as I said and Speaker output is displayed as “unavailable”.

I wanted to try hdajackretask as suggest here but did not work (also I’m not sure if it is compatible with NixOs configuration ? And don’t really know how to use it).

Does someone have an idea ?

I continue digging.
Someone seems to have found a solution on debian : No speaker audio on Latitude E6420 - Debian User Forums

Speaker+LO is also mute by default, but if I unmute it, it’s the same.
The problem is that when I launch alsamixer, it started with a generic “PipeWire” card name instead of my Intel one…

When I select the Intel I got that :

It seems that the default card is wrong, how can I specify the default alsa card ? :
Capture d’écran du 2024-03-25 09-46-12

Also how can I disable “auto-mute” on alsa ?


I don’t know what I’ve done, but yesterday sound started to get out of my speaker !
I haven’t done anything special, I didn’t change my configuration, didn’t update anything, a mystery really :astonished: !

By the way, I tried on latest Linux Mint and got the same audio problems. Maybe it was a “random” hardware problem that will come back later…