No wifi on fresh install (KDE Plasma)


First time using NixOS. I have had troubles getting my wifi usb adapter working before on arch-based distro EndeavourOS, but I finally got it working with:
yay -S rtl88xxau-aircrack-dkms-git

I tried this
sudo nix-env -i rtl88xxau-aircrack
seems it didn’ t do much.

I also changed stuff in configuration.nix

1 tried just uncomment this line:
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.

then 2

 networking.networkmanager.enable = true;
  networking.wireless.iwd.enable = true;
  networking.networkmanager.wifi.backend = "iwd";

  # networking.hostName = "nixos"; # Define your hostname.
  # networking.wireless.enable = true;  # Enables wireless support via wpa_supplicant.

  # Configure network proxy if necessary
  # networking.proxy.default = "http://user:password@proxy:port/";
  # networking.proxy.noProxy = ",localhost,internal.domain";

I have 2) now. Still nothing.

No idea what I should be doing. Some guidance would be really welcomed.

Is this in a live CD enviroenment, or in a freshly installed system? (if it is an installed system, was wifi working in a live CD env)?

I don’t know how to diagnose or verify if this is what happens here, but one problem I’ve run into previously was that the driver for my wifi adapter was proprietary, and thus wasn’t packaged into the default live CD environment. To fix this problem (again, can’t say if this is the problem here), you need to allowUnfree in nixos settings, and you might need to explicitly add the relevant kernel module.

If you need to do this for a live CD env, you can build a custom live CD like this:

1 Like

Try it:

boot.extraModulePackages = with config.boot.kernelPackages; [
1 Like