OBS Studio (Flatpak version) can't record audio

Hello anyone.
I have problem from OBS Studio installation from Flatpak. It can’t record audio input. I haven’t idea how to fix it because in Flatseal microphone slider in Flatseal is disabled. Please help me to solve this problem. I attach any relevant information about this problem.

This is my OBS Studio configuration (get focused to “Source” section)

It disabled on Flatseal and it can’t change to enable it

This is my audio configs

   # Enable sound with pipewire.
   sound.enable = true;
   hardware.pulseaudio.enable = false;
   security.rtkit.enable = true;
   services.pipewire = {
     enable = true;
     alsa.enable = true;
     alsa.support32Bit = true;
     pulse.enable = true;
    # If you want to use JACK applications, uncomment this
    #jack.enable = true;

My Nix info

$ nix-shell -p nix-info --run "nix-info -m"
 - system: `"x86_64-linux"`
 - host os: `Linux 6.1.90, NixOS, 23.11 (Tapir), 23.11.6827.383ffe076d9b`
 - multi-user?: `yes`
 - sandbox: `yes`
 - version: `nix-env (Nix) 2.18.1`
 - channels(root): `"android-nixpkgs, home-manager-23.11.tar.gz, nixos-23.11, nixos-hardware, nixos-unstable"`
 - nixpkgs: `/nix/var/nix/profiles/per-user/root/channels/nixos`

I install NixOS on ThinkPad X280

You’re using Pipewire, which could be breaking things (I know it breaks Musescore at least), try Pulseaudio – replace your sound section with this (and change things if needed):

  sound.enable = true;
  hardware.pulseaudio = {
    enable = true;
    support32Bit = true;
    extraConfig = "load-module module-combine-sink";
  security.rtkit.enable = true;

Also don’t forget to add “audio” to your extraGroups in your user section. Here’s some more explanations on this code: PulseAudio - NixOS Wiki

This problem solved with change to unstable channel for core system and using OBS Studio from Nixpkgs