Omnisharp, not found

I have this topic, which got solved:

, but I face the same issue if I run omnisharp:

A fatal error occurred. The required library could not be found.
If this is a self-contained application, that library should exist in [/nix/store/y0y6vlc2vz9l60ipivx2sz9c8h5j9wy1-omnisharp-roslyn-1.38.2/src/].
If this is a framework-dependent application, install the runtime in the global location [/usr/share/dotnet] or use the DOTNET_ROOT environment variable to specify the runtime location or register the runtime location in [/etc/dotnet].

The .NET runtime can be found at:
env|grep -i dotnet_root

ok, solved it.

There’s a bug in “stable”.

, so I grabbed omnisharp from unstable:

  unstable = import (fetchTarball {};

  environment.systemPackages = with pkgs; [

ok, turns out, that link was wrong, cause I actually got an older version, which worked, but I need the newest one

the url is actually:

  unstable = import (fetchTarball {};

so, this one is the newest in unstable, but it has this problem;)

So, any pointers from here?

ok, I forgot to declare unstable.omnisharp here. Sorry. Working;)