Openfortivpn VPN connection failure

I am trying to connect to a Fortigate SSL VPN using the Openfortivpn client, and the connection is failing with the message: Peer refused to agree to his IP address. This worked on my previous NixOS 22.11 installation (hard drive failed). Current version is NixOS 23.05.1906.8163a64662. It is probably a configuration issue, but I am not sure where to look. Can anyone point me in the right direction? Here is the connection sequence I am seeing, and thank you for any help that you can provide:

VPN account password:
INFO: Connected to gateway.
Two-factor authentication token:
INFO: Authenticated.
INFO: Remote gateway has allocated a VPN.
Using interface ppp0
Connect: ppp0 ↔ /dev/pts/1
INFO: Got addresses: [], ns [,]
INFO: Negotiation complete.
INFO: Negotiation complete.
Peer refused to agree to his IP address
Connect time 0.1 minutes.
Sent 1101 bytes, received 1081 bytes.
ERROR: Timed out waiting for the ppp interface to be UP.
INFO: Cancelling threads…
INFO: Cleanup, joining threads…
Hangup (SIGHUP)
Modem hangup
Connection terminated.
ERROR: pppd: The link was terminated by the modem hanging up.
INFO: Terminated pppd.
INFO: Closed connection to gateway.
INFO: Logged out.

I had that as well. Upstream knows about it and the next release should have it, and for me it fixed it, as I was able to test with

$ nix shell --impure --expr '(builtins.getFlake("nixpkgs")).outputs.legacyPackages.x86_64-linux.openfortivpn.overrideAttrs(old: {src = builtins.fetchTarball;})'

(isn’t that a great way to test a pre-release…)

I think it’s this commit:

So you need openfortivpn-1.20.4 at least.

Great! Thank you for this information.