Package ‘python3.10-python-efl-1.26.0' is broken and thats stopping me from installing enlightenment

decided to try out the new debian 12, why i didnt spin up a vm ill never know but i decided to wipe my nix install to do it. i realized i had made a mistake and went to re-install nix, when it tried to install the enlightenment DE however, it failed saying that the python-efl package was broken and booted me out. heres the log:

    ERROR: Installation failed: "nixos-install failed" 
2023-06-30 - 15:15:12 [6]:     .. - message: "nixos-install failed" 
2023-06-30 - 15:15:12 [6]:     .. - details: copying channel...
building the configuration in /tmp/calamares-root-x2yj5zw7/etc/nixos/configuration.nix...
error: Package ‘python3.10-python-efl-1.26.0’ in /nix/store/4lv6nn8yfp1ddvzw4gpbcrb1k00j26br-nixos-23.05.1375.9790f3242da/nixos/pkgs/development/python-modules/python-efl/default.nix:46 is marked as broken, refusing to evaluate.

       a) To temporarily allow broken packages, you can use an environment variable
          for a single invocation of the nix tools.

            $ export NIXPKGS_ALLOW_BROKEN=1

        Note: For `nix shell`, `nix build`, `nix develop` or any other Nix 2.4+
        (Flake) command, `--impure` must be passed in order to read this
        environment variable.

       b) For `nixos-rebuild` you can set
         { nixpkgs.config.allowBroken = true; }
       in configuration.nix to override this.

       c) For `nix-env`, `nix-build`, `nix-shell` or any other Nix command you can add
         { allowBroken = true; }
       to ~/.config/nixpkgs/config.nix.
(use '--show-trace' to show detailed location information)

2023-06-30 - 15:15:12 [6]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    Calamares will quit when the dialog closes. 
2023-06-30 - 15:15:12 [6]: QML Component (default slideshow) deactivated
2023-06-30 - 15:15:12 [6]: void Config::doNotify(bool, bool)
    Sending notification of completion: failed 

It is fixed in the unstable, are you using flakes?
@Nim like Nim Lang?

I’m also hitting this issue. I’m just using the graphical installer so I don’t know if it’s using flakes or not. I tried running Calamares from the command line with NIXPKGS_ALLOW_BROKEN=1 from the command line and it doesn’t seem to have helped :confused:

1 Like

no, not using flakes. i just installed with lxqt but do you think switching to unstable will fix the issue? if so how would i do that? thanks!

sudo nix-channel --list
sudo nix-channel --remove nixpkgs
sudo nix-channel --add nixpkgs
sudo nix-channel --update
sudo nixos-rebuild switch

You can install any other DE (like gnome/kde) whatever works for you, install
update channels (my previous message)

change /etc/nixos/configuration.nix
Replace gnome/kde (whatever worked for you) with enlightenment

  services.xserver.desktopManager.enlightenment.enable = true;

sudo nixos-rebuild switch
reboot # just in case :wink:

If you have flakes enabled there is a /etc/nixos/flake.nix (or you can create one) with

  inputs.nixpkgs.url = "github:NixOS/nixpkgs/release-23.05";

Just change it to

  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";

Technically, if you are using flake, your configuration may be anywhere :smiley:

That means you could move /etc/nixos to anyware (ie. $HOME/wherever-you-leave-your-personal-code/mine-is/Code/nixos) add it to git and install/reinstall with

# do this from you source code directory
sudo nixos-rebuild switch --flake .#$(hostname)

Even use a git repository like

sudo nixos-rebuild switch --flake github:USER/REPO#HOSTNAME
# sudo nixos-rebuild switch --flake github:hugosenari/nixos-config#BO

edit: fix unstable git URI

This will use the master branch of Nixpkgs, which has all the changes that come before nixos-unstable (it’s more unstable than Unstable itself) and isn’t cached by Hydra (you will end up building a lot of packages on your machine).

To use the nixos-unstable branch you have to specify it in the input’s URL:

-  inputs.nixpkgs.url = "github:NixOS/nixpkgs";
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
1 Like

I found the PR that fix that pythonPackages.pythonefl: broken only with python 3.11 by romildo · Pull Request #231956 · NixOS/nixpkgs · GitHub
Ask them to backport it [Backport release-23.05] pythonPackages.pythonefl: broken only with python 3.11 by github-actions[bot] · Pull Request #241979 · NixOS/nixpkgs · GitHub
May be in Release 23.05, some time.

I didn’t know that, thank you. :slight_smile: