Packages not installing with nix channels

I tried all of the standard update applyers but none seemed to work. sudo nixos rebuild --upgrade boot did not work, sudo nixos- rebuild switch --upgrade did not work I updated my channel to unstable, nothing worked

What version of nix are you on? (nix-env --version)

Are other changes to your configuration persisted properly? Eg if you add or remove items to/from environment.systemPackages, is this reflected in the system after a switch?

I don’t use nix-env (I use config.nix and home.nix) but my version is nix-env (Nix) 2.13.3

I just asked for nix-env --version as that usually puts the proper version of the nix toolchain. Whether you use it or not isn’t relevant.

So my usualy assumption that the upgrade simply doesn’t work because of the nix 2.14+ XDG issues us busted :frowning:

Unless you have a different nix in PATH, therefore I’d like you to run sudo nix-env --version as well.

Also I’d like to know more about your channels, can you please share the outputs of sudo nix-channel --list and nix-channel --list?

Sudo nix-env version returns the same thing, nix channel list shows unstable: nixos nixos-unstable release nixos-23.05pre484945.963006aab35 and sudo returns the same

As the output might have been possibly mangled by the forum software, I assume the output actually is:


If my assumption is true, then please remove the users nixos channel (nix-channel --remove nixos).

After that please run for chan in nixos nixpkgs; do printf "%s: %s\n" $chan $(nix-instantiate --eval --expr "(import <$chan> {}).lib.version"); done, which will probably print the same information for both channels, still I want to see both to be sure.

Please post your reply using markdown, such that it won’t get mangled by the forum again:

nixpkgs: "23.05pre-git"

Your printed versions will probably look different, as I have some flake setup that reflects itself via the nix path entries, and doesn’t provide the necessary version information.

1 Like

Your assumption is true and the command shown does not do anything

Which assumption is true? That the command showed the same version for both?

Which command doesn’t do anything? The for-loop things with the nix-instantiate? It should have printed something, and I am interested in this output. That command was not meant to “do” anything but collecting some information about the state of your system, namely what exact channels and commits you are on.

The channel that you showed that the fourm mangled is correct, and it was the for chan in nixos nixpkgs; do printf "%s: %s\n" $chan $(nix-instantiate --eval --expr "(import <$chan> {}).lib.version"); done command, no printing occured it just sat

Wdym, it just sits?

That command really should print something.

And if it’s just errors.

Depending on your machine it can take a while of course.

My low end potato needs about 3 minutes per channel.

ok, I am somtimes inpatient and ctrl+c things so I will let it sit. My pc is also quite slow