Picom and touchpad

Hello, I’m pretty new to NixOS :))) and I wondered how can I install picom, as the usual nix-env -iA nixos.picom doesn’t work (didn’t find anything on internet).
Also, I have a problem with my touchpad :c, sometime, he freezes for a minute and he’s back to normal, but all I can do is waiting, although I can use my keyboard. I tried using an external mouse, but it doesn’t work, but that’s another problem that I can figure out on my own I think.
Well, basically I think that’s all for my problems at the moment.
I must specify that I’m running on NixOS 20.03 with i3 as window manager and no desktop environment. I tried building it from the source code but the meson command doesn’t work perfectly, don’t know why. If it has anything to do with my problem, I can surely put the ouput of the command here, let me know. Thank you for taking time to read it and eventually answer :smile:

In what way does it not work?

If it missing, what does nix-channel --list show?

It simply tells me error: attribute 'picom' in selection path 'nixos.picom' not found. And nix-channel --list returns home-manager https://github.com/rycee/home-manager/archive/release-19.09.tar.gz

You need to add the nixos channel.

nix-channel --add https://nixos.org/channels/nixos-20.03 nixos
nix-channel --update

The root user and your normal user have separate nix-channel configs.

1 Like

didn’t know that haha thank you, now I have to figure out the problem about the touchpad…

1 Like

You shouldn’t install picom with nix-env, you should use the nixos option in configuration.nix NixOS Search - Loading...

sorry, I’m pretty new, what do I have to put in my configuration.nix then ?

services.picom.enable=true; would be a good starting point.

yeah that’s what I thought, thanks c: and last question, is compton.service in fact picom.service ?

services.compton is an alias for services.picom


1 Like