Picom true transparency not working

I am running NixOS 23.05. Currently, I enable picom in NixOS with the following in my configuration:

services.picom = {
enable = true;
backend = “glx”;

Strangely, this configuration allows for me to set windows to be transparent, but if I try to enable transparency through a particular application like alacritty so that the background is transparent but the text is opaque there is no effect and the whole window remains opaque. If I disable the picom service and run picom myself with my own configuration file, it also gives the same result. It is strange because the very same configuration file works on my other computer which has Arch. Anyone else have this issue? Any idea how I might start troubleshooting this?

Many thanks!

I remember a problem similar to that, but I think I had it on Archlinux a few years ago…

Can you set the transparency with alacritty if picom is disabled? And what window manager/desktop do you use?

I cannot set transparency on Alacritty with or without picom. I currently use awesome window manager and have all the same config files between my nixos and arch devices. Maybe it has to do with the version of picom that nixos uses by default?