Pipewire device is connected but no audio playing

Hi there.
My audio has been working perfectly up until now where it will show output to my headphones but no noise is heard. It works fine on my bluetooth headphones. I know the issue is not with my headphones as they work fine on my windows partition.

My pipewire config

{ pkgs, ... }:

  # Enable sound with pipewire.
  sound.enable = true;
  hardware.pulseaudio.enable = false;
  security.rtkit.enable = true;
  services.pipewire = {
    enable = true;
    alsa.enable = true;
    alsa.support32Bit = true;
    pulse.enable = true;
    jack.enable = true;
  environment.systemPackages = with pkgs; [

Have you tried messing around in the “Output Devices” tab of pavucontrol? Perhaps you need to change which device is set as a fallback. Also since you have jack enabled you could install helvum to get a graphical view of where audio is getting piped.

Heres the result from helvum.

Heres the available output devices.

Update: I fixed it by just reinstalling nixos and cloning my configs again. Sure there would’ve been an easier way but I couldn’t be bothered to figure it out.