Plasma Wayland session not available from SDDM

'Been using Plasma X11 on NixOS for a while and I like it. However I wish I had the option to try out Plasma Wayland right from my login manager (SDDM). The issue is, the option / selector is absent from the login screen.

Here’s the relevant part of my configuration:

services.xserver.enable = true;
  services.xserver.videoDrivers = [ "intel" ];
  services.xserver.useGlamor = true;
  services.xserver.displayManager.sddm.enable = true;
  services.xserver.desktopManager.plasma5.enable = true;

I am however able to start a wayland session by using:
dbus-launch startplasma-wayland from a tty. The problem is that it’s not how Plasma Wayland expects to be started, and it will cause many small issues down the line.

Thanks in avance for any help!

PS: The rest of my config:

Operating System: NixOS 21.11pre293089.1c2986bbb80
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Kernel Version: 5.12.7
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 15.5 Gio of RAM
Graphics Processor: Mesa Intel® HD Graphics 530
1 Like

Should anyone finds themselves facing the same issue: I’ve managed to get my wayland session with

services.xserver.displayManager.sddm.settings.Wayland.SessionDir = "${pkgs.plasma5Packages.plasma-workspace}/share/wayland-sessions";

Thanks very much to the Telegram user @Congrav1ty for that!


See also Plasma Wayland · Issue #43757 · NixOS/nixpkgs · GitHub and the PR associated with it. Here is one blocker: Notifications and other popups are treated like "normal" windows on Plasma Wayland · Issue #118650 · NixOS/nixpkgs · GitHub