Playing HDMI audio when screensaver is on?

My audio and video signal are both going through the same HDMI cable. It seems that when the GNOME screensaver activates, it breaks the HDMI signal completely, so the audio signal isn’t going through anymore.

Looking at the power and screen settings, there’s nothing that seems relevant for making sure the audio signal isn’t interrupted. There isn’t even an option to make sure the signal just sends a black image rather than turning off.

(Disabling the screensaver is not an option, even if it’s for a single application. I just want to be able to play sound while the screensaver is active.)