Prevent Installed Service From Autostarting (fcitx5)

Hello, I’m trying to get fcitx5 working on plasma 6. Here is my current configuration:

    i18n.inputMethod = {
      enabled = "fcitx5";
      fcitx5 = {
        plasma6Support = true;
        waylandFrontend = true;
        addons = with pkgs; [ fcitx5-mozc ];
      };
    };

This installs fcitx, and I can see it in my Plasma settings, but I’m not able to set it to my input type, and there’s some other weird bugs.

I think these issues arise from fcitx starting by itself and not being controlled by Plasma (a notification gets sent on startup about removing fcitx from autostart).

So I’ve been trying to get the fcitx service from not automatically starting. I’ve found where it gets started from, but I don’t think there is a service being created from within Nix, it just found an autostart file in the installation.

Service name: app-org.fcitx.Fcitx5@autostart.service

Service file location: /run/current-system/sw/etc/xdg/autostart/org.fcitx.Fcitx5.desktop symlinked to: /nix/store/...fcitx/etc/xdg/autostart/org.fcitx.Fcitx5.desktop

So my question is is there an easy way to blacklist this specific item from running? I think I could make a package derivation, but I don’t think that’s the best solution.

Here’s the notification:

Fcitx should be launched by KWin under KDE Wayland in order to use Wayland input method frontend. This can improve the experience when using Fcitx on Wayland. To configure this, you need to go to “System Settings” → “Virtual keyboard” and select “Fcitx 5” from it. You may also need to disable tools that launches input method, such as imsettings on Fedora, or im-config on Debian/Ubuntu. For more details see Using Fcitx 5 on Wayland - Fcitx

UPDATE: Seems the issue with fcitx5 is with something else, but knowing how to disable this would be useful still.