Problem Importing Jovian Nix Flake Module, "Attribute Missing"

I have a NixOS Jovian machine that randomly starting to have it’s updates fail and I’m really scratching my head why. Here is the overview of what I’m doing in my flake.nix:

  inputs = {
    nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
    jovian-nixos.url = "github:Jovian-Experiments/Jovian-NixOS";

  outputs = inputs @ { self, nixpkgs, jovian-nixos, ... }:
      mkComputer = system: configurationNix: extraModules: inputs.nixpkgs.lib.nixosSystem {
        specialArgs = { inherit inputs nixpkgs; };
        modules = [
        ] ++ extraModules;
        nixosConfigurations = {
          hostname = mkComputer

And with this I get

       … while calling the 'seq' builtin

         at /nix/store/v30afjhzqrwra6mkizz12az6dbryg7pr-source/lib/modules.nix:322:18:

          321|         options = checked options;
          322|         config = checked (removeAttrs config [ "_module" ]);
             |                  ^
          323|         _module = checked (config._module);

       … while evaluating a branch condition

         at /nix/store/v30afjhzqrwra6mkizz12az6dbryg7pr-source/lib/modules.nix:261:9:

          260|       checkUnmatched =
          261|         if config._module.check && config._module.freeformType == null && merged.unmatchedDefns != [] then
             |         ^
          262|           let

       (stack trace truncated; use '--show-trace' to show the full trace)

       error: attribute 'default' missing

       at /nix/store/vmz5gfmn17v593jphvslyh74vbj48ch2-source/flake.nix:161:13:

          160|           [
          161|             jovian-nixos.nixosModules.default
             |             ^
          162|             nix-flatpak.nixosModules.nix-flatpak

But the Jovian flake.nix clearly has this module:

nixosModules = rec {
  default = jovian;
  jovian = ./modules;

I’ve tried both “default” and “jovian” and there is indeed a modules folder there which should import everything with a default.nix. I’m able to use other flake modules in this exact manner, what am I doing wrong?

This indicates that your flake.nix is different from the one in the post. Can you link the repo? Most likely the reason is that jovian-nixos is not being passed to the import site properly.

I tried the flake.nix from your post (stubbing out ./hosts/hostname.nix with something reasonable) and it passes nix flake check.

Thanks for the help. I had jovian-nixos.follows = "nixpkgs-unstable"; in my config, removing it fixed it. No idea why, when I build it even says Updated input 'jovian-nixos': follows 'nixpkgs-unstable'. Probably should have added that to my example, sorry.