Problem running the graphical installer

I currently am trying to install NixOS, on my Lenovo Ideapad 5, with the 11th gen Intel i5 processor. On booting through a bootable USB, I end up in a tty. On running sudo systemctl status display-manager, I can see that the service is active with no errors. If it helps I am also attaching the end of dmesg.

I think the problem might be related to Intel’s iris Xe Graphics requiring a newer kernel. How can I get over this issue?

do you need the GUI to actually install?

If not, you can just go through the normal installation steps, from this tty and boot nixos proper…

What kernel do you think you need?

there is no graphical installer, just a shell that allows you to modify your configuration.nix , a graphical install is in the works… but you will learn a lot more by going thru the installation guide at a shell prompt!

Thanks for the reply,

I’m not too sure.
I mentioned the kernel idea from here. It’s related to Ubuntu, but the problem and the logs appear similar to mine.

That’s true but even if I’m able to install it successfully, won’t I still run into the same problem?

depends… once you have the system stood up, there are opportunities to upgrade and downgrade your kernel. or use 20.09 or unstable, or roll forward or back with a nixos-rebuild switch

so i would get a full nixos system working without X or Wayland, and go from there as a starting point.

ps. welcome to Nix/OS , i hope you have some fun here.

Cool, I’ll try to get it up and running.

Looking forward to it.

There is quite a lot of resources, and friendly people to get you up and running. Here is good, IRC, discord, and a few other places the nix’ers have colonised.

1 Like

I believe you just need a newer version of kernel packages,

boot.kernelPackages = pkgs.linuxPackages_5_9;

should fix your issues. This will install the 5.9 linux kernel and related modules. 20.09 should have this version as well.


@nixinator @jonringer Thanks for the help. I’ll update you folks on the progress.

Okay, so I’m having another problem. While running cfdisk, I can see only one device, the USB drive. lsblk also lists just the USB drive. Any idea why this would be happening?
Update: I tried booting up a Manjaro Bootable, and the rest of the devices (my hard drive and ssd) show up for it.
Also, please do let me know if I should create a separate topic for this issue.

Try adding the following kernel parameter when booting:


If I recall the NixOS live system uses grub, so you can press ‘e’, add the parameter shown above, and then press ENTER to book.

1 Like

Tried it, didn’t work. Plus, both my HDD and SSD aren’t showing up, not just the SSD.

Hmm… sounds like a kernel module you need for hdd/ssd controller hardware is missing, not supported or not working. A dump from dmesg on both a working O/S and a Nix/OS might be helpful.

A lsmod, again of both a working system and non-working system might give a clue on what is missing.

doesn’t seem to yield much clues.

The ideapad 5 was release by the manufacture in January… So i can probably see why it’s problematic :-).

However… it would be nice to get it working under Nix/OS.

On going through some of the old issues like this, I can see that newer hardware can sometimes be problematic due to the installer using an older kernel.
Is there a recent iso build that uses a newer kernel?

Okay, found a build which I guess should have a more recent kernel. Will give this a try.

I can see why installers don’t have blistering new kernels. Sometimes it better the devil you know, than cutting edge/bleeding edge/over the edge software.

A trade off between latest everything, and something that’s stable and battle tested… lucky in nix/OS you can get the best of both worlds once your system is up and running.

With new hardware , it’s a case of reverse engineering much of the hardware and device drivers… :slight_smile: . What surprises me that any linux works so well, even when faced with developers coding in the dark and having to reverse engineer windows drivers… ,Hardware manufactures invest time and money in windows drivers exclusively , leaving linux and other operating systems as second class citizens…

but it does work…somehow…with a lot of sweat and talent. Using Nixos has taught me where all this ‘software’ comes from and i’m just completely impressed by the ‘community effort’. You ever thought where a certain subsystem comes from, and who’s behind it… . the answer is just a nix edit away! :slight_smile:

Lets hope Risc V and more open hardware saves us… !

Buy hardware from vendors that actually want to support linux as a first class citizen and have open designs/documentation.

Good luck, I hope you ‘Nixify’ this snazzy new piece of hardware!

1 Like

On my Dell XPS 15 I have to turn on AHCI (vice RAID) in BIOS to get the drives to show up.

I totally agree but, it would be nice to have the images with the newer kernel readily available alongside the stable ones, as I had to dig around quite a bit to find it ;p.

Please correct me if I’m wrong here, but I believe most manufacturers do support Linux (mainly due to its wide adoption in servers), except of course some dreaded ones (like Nvidia :P).

Hoping to learn a lot from it :).

1 Like

Thanks for the suggestion, but I got it working by using an image with a newer kernel (5.11 to be exact).
Finally got NixOS installed, gonna start configuring now :).

1 Like