Problems with F2FS

#1

Problems with F2FS.

I’ve had a rather strange issue with F2FS in NIxOS that actually forced me to re-partition a particular machine.

Said machine had an NVME SSD and this was a fresh install of 19.03.

Story is as follows

  • Installs NixOS with a completely blissful joy
    (imagine Julie Andrews the hills are alive style)

  • Boots NixOS and things are kinda weird

fsck.f2fs would stall for about >=20s in an almost consistent manner.
Anytime I would do nixos-rebuild * and boot the new generation it would stall this way.

Progressively fsck would take more and more time after more rebuilds and reboots.
Even more so if I switched a kernel.

  • Can’t boot because fsck won’t exit

This was understandably frustrating for me.
However I still held true.

  • Does some seeking

Things I noticed

Note this a wasn’t a particularly invested investigation.
I could always change the filesystem and move on.

But I was really confused by how it appeared that fsck was an aggressor here.

I thought to skip fsck and see if we could move on, but I couldn’t achive this for some reason, even with noCheck.

Long story short did some diagnostics and there wasn’t anything wrong.

“Solution”

Didn’t use f2fs.

Not particularly the one I wanted, but I’ve tried other filesystems and haven’t had any problems.
So maybe there’s a problem in NixOS?

Reflection

Hardware could be at fault, I doubt it though, but I wouldn’t wish this experience on someone.
I’d be consenting to it by means of complacency.

I’ve posted this to inquire if anyone else has had these issues with F2FS.

0 Likes

#2

Hello,

I’ve posted this to inquire if anyone else has had these issues with F2FS.

In the past I’ve tried it before going with nilfs2, it was on NixOS
stable, 17.09. I do not have had such fsck problem but f2fs cleaner
seems to be even worse than nilfs2 one, to a point that I’ve get
regular fs full issue due to lack of cleaning and no way to push
cleaner run a bit. Second problem f2fs prove to be really unstable
for me, I have random file loss on a working Intel ssd that is
still working and in good shape today…

However I do not have non-NixOS experience with it so I can’t tell
if NixOS support have a bug or it’s f2fs itself. The sole thing I
can say is that f2fs is still alive but certainly nearly in
maintenance mode on GNU/Linux…

– Ingmar

0 Likes

#3

The fsck can be disabled with: boot.initrd.checkJournalingFS = false

0 Likes