QT Platform Plugin

I’m trying to modify a package (houdini) to the latest version, and added the additional libraries required but stuck getting it to run. Trying to run the application i get the following

~ $ houdini
Qt Error: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

i tried doing libsForQt5.callPackage ./runtime.nix in the default.nix and also tried adding

nativeBuildInputs = [ wrapQtAppsHook ];

to the runtime itself.
I can see similar errors online about could not find the Qt Platform plugin “xcb”, but it appears my userenv isnt even specifying the xcb or any other. Is libsForQt5 and wrapQtAppsHook just for buildtime? AFAIK i shouldnt need to include any qt libs for this package as they are bundled in the application itself

Here is the runtime.nix that i’ve modified