QtEmu Setup Help

I’m new to NixOS and want to use QtEmu for emulating a virtual maschine.
but when i start it, it asks me for some things:

what should i do there?

would be very happy about awnsers.

Try running dirname $(readlink $(which qemu-system-x86_64)). You should get something like /nix/store/...-qemu-8.2.1/bin where the ... is a bunch of letters and numbers. Paste that into QEMU binaries path. QEMU img path can be similarly obtained with readlink $(which qemu-img). QEMU machines path is wherever you want all of your VMs to be saved. If you are migrating from an existing installation of QtEMU the machines path should point to the machines path of your old installation if you want to keep using your old VMs (unless you moved that folder or it contents as part of said migration, in which case point it at the destination folder). Make sure the machines path (and only the machines path) does not begin with /nix/store/.

1 Like

well, first worked well, but then i tried to start a virtual maschine, and this appears:

Just to check, QtEmu was installed via environment.systemPackages, right?

yes, i used that. why?

That’s strange, this should mean that QtEmu should already have the QEMU binaries in its PATH.

what to do now?

Could you tell me what which qemu-system-x86_64 and uname - r return?

$ witch qemu-system-x86_64
$ uname -r

As a stopgap, maybe try setting the binaries path to /run/current-system/sw/bin?

doesnt really works, getting another error:

That’s just QtEmu being outdated, sadly. The -soundhw option was deprecated by upstream QEMU. See here.