Qutebrowser cursor problems

When I hover the cursor over these styled words:

  • alias
  • copy
  • grab
  • pointer

in the following link:

they all display the same “grab” cursor. Also, sometimes the cursor disappears altogether, and by flinging the pointer over different elements of the screen (usually up to waybar), I can restore the visibility of the cursor. Previously, I have not had this problem. Something recently updated to cause this problem.

I tried a different browser and the above cursors all display correctly and differently from one another.

I am running Hyprland and am on the unstable channel of nixpkgs.

I’m not sure if this is the right place to get answers to your problem. It seems more something to do with qutebrowser than Nix.

However, I just tried what you say and it works fine for me (also in qutebrowser).

So my suggestions are:

  1. Upgrade your system, maybe some package needs it.

  2. Make sure you have a theme with enough cursor icons (which I think you have, because it works in other browsers).

  3. Take a look at the qutebrowser repository issues. Maybe someone has reported something similar. If not, I think the best thing to do is to open an issue yourself.