Raspberry Pi 3B+ ethernet stopped working

Hi all,

I’ve previously had no problems using Ethernet with NixOS on my Raspberry Pi 3B+, but as I’m continuing to try to get a solid BTRFS-based image (https://discourse.nixos.org/t/raspberry-pi-nixos-on-btrfs-root/), my most recent image results in no IP address or network connection on eth0.

Relevant config, on 22.05:

 networking = {
    hostName = "nixpi";
    useDHCP = false;
    interfaces = {
      eth0.useDHCP = true;
    };
    firewall.enable = false;
    wireless = {
      enable = true;
      networks = {
        "MyWifi" = {
          pskRaw = "totally Real";
        };
      };
    };
  };

Elsewhere in hardware-configuration.nix:

 networking = {
    useDHCP = lib.mkDefault false;
    interfaces.eth0.useDHCP = lib.mkDefault true;
  };

In ip addr I can see eth0 but no IP address, and no DHCP request that I can see in my pfsense logs.

No help with systemctl restart dhcpcd.service, no obvious error messages. No help unplugging and replugging the LAN cable both ends. No help with a nixos-rebuild --upgrade switch. If I change the wireless credentials I can get wlan0 working, but still no IP address on eth0.

What am I missing?

I tried running dhclient manually but it’s not found – what manual steps can I take to solicit an IP address and debug this? The Ethernet adapter has previously been working on this Pi, so I don’t suspect a hardware issue.

TIA for any suggestions!

Looks like it may have been from specifying a more recent kernel. Dropping back to the default kernel seems to have fixed things.

Nope, issue is back in spite of using the default kernel.

I see in the logs that eth0 is waiting for carrier.

Hosted by Flying Circus.