Raspberry Pi 4 - flickering screen

I tested multiple hydra images and all recent ones have this flickering screen problem.
Even the image listed in:

The image that worked I found in:

Working image: nixos-sd-image-21.03pre262561.581232454fd-aarch64-linux.img

Is this a known problem or am I missing something?

I also updated the firmware using rpi os.

### Raspberry Pi OS on sd-card
unzip -p ~/downloads/2021-05-07-raspios-buster-armhf-full.zip | sudo dd of=/dev/sdX bs=4M conv=fsync status=progress
# boot raspberry pi os
sudo setxkbmap us -variant colemak
sudo rpi-eeprom-update
sudo rpi-eeprom-update -d -a
sudo reboot
sudo rpi-eeprom-update # This should tell it's up-to-date

Are you sure that the cable you’re using is fine?

I’ve tested the nix.dev image and it worked fine for me. Given that the tutorial is reproducible, I’d start by assuming something is going on with hardware.

Tried different cables and psu.
It works for only 1 image I tested, out of 15 and counting.
The official raspberry pi os full desktop also works without flickerings.

Today I follow the nix.dev tutorial again.
This time I also updated the bootloader, using the Raspberry Pi Imager method.
The screen kept flashing/flickering.
What I changed:

  • rpi4 4gb & rpi4 2gb
  • 5 hdmi-microhdmi cables
  • 3 psu
  • 2 sd-card & 4 usb-sata adapters & 6 ssd

The older Nixos image worked without flashing: https://hydra.nixos.org/build/134720986/download/1/nixos-sd-image-21.03pre262561.581232454fd-aarch64-linux.img.zst
The Raspberry Pi OS worked without flashing.

1 Last change, The TV:

  • Loewe Art 32, keeps flashing.

Now I tried with a recent Medion TV. It works.
I don’t know why… Older hdmi spec ?

tldr: The tv is the cause of all these problems.

1 Like

follow up:

I followed the tutorial and installed the example nixos config.

Now I tried to boot the rpi4+sdcard with the “bad” tv.
During the boot process it flickers/flashes for 2 seconds during Stage 1.
Before and after I don’t see any flickering.