Raspberry Pi USB Hub Issues

I have been trying to get my Raspberry Pi 4 (4GB) to boot from an external SSD. The issue is that the SSD uses up too much power, so I need to connect it to a powered USB hub to avoid disconnects. However, it doesn’t seem to boot when any drive required at boot is connected to a USB hub (powered or not). I can mount the drive normally after booting, and it seems to work just fine. When using a usb hub on the latest image, the display just powers off on both HDMI ports right before it would normally show me the login prompt. The system.journal file doesn’t seem to contain anything out of the ordinary, and it’s different every time, so I don’t think it will be of much use. Everything works fine on Raspberry Pi OS, and I can boot my PC just fine from the USB hub. This is driving me crazy. I’ve tried:

  • Updating the EEPROM
  • Using a different disk
  • Using a different USB hub
  • Using the config from Installing NixOS on a Raspberry Pi
  • Using a different image
  • Having the firmware on my SD card and mounting the external drive as my root directory
  • Adding the all-hardware module to my config (which breaks everything)
  • Adding these kernel modules to my initrd: uas, pcie-brcmstb, reset-raspberrypi
  • Other things I’ve forgotten about

I really hope someone out there can help me with this. It’s my first time having to ask for help on a public forum like this.

Have you tried to change the boot order? also move /boot partition onto the SSD?
e.g https://forums.raspberrypi.com/viewtopic.php?t=286076#p1731139 (and below comments)

I tried using the Update Bootloader EEPROM and Update VL805 (USB) EEPROM options inside Raspberry Pi EEPROM Manager (running it in raspberry pi OS because it wouldn’t work on NixOS even after fixing the shebang), as well as setting BOOT_ORDER=0xf41 in the boot loader configuration. The boot order seems fine and I can boot from a USB drive just fine, but as soon as I connect that same disk to my USB hub NixOS gets stuck in the NixOS Stage 2. I don’t have this issue with raspberry pi OS.

Any logs / errors similiar to that? Rpi3: usb disk disconnected during Stage 2

I didn’t get any errors like that, but for I tried blacklisting the onboard_usb_hub kernel module and it looks like it actually works… I can’t believe it, I actualy saw that same post earlier today but then I didn’t finish implementing their fix until you reminded me of it. Nevertheless I thank you for for dedicating your time to fixing my stupid issue, JimJ92120

Oh, and this should probably be at the very least mentioned on the wiki somewhere until it gets fixed.

1 Like