Renpy game that are made for linux doesn't run

Hello, I’m trying to play a Renpy game, I migrated to NixOS today so my system is rather fresh. I tried to execute the .sh file my file browser and nothing happened so I checked with ./ and got the following message: ./ line 67: /run/media/user/hdd/Games/game/lib/linux-x86_64/game: cannot execute: required file not found I checked if the file was there and it is, I also tried with multiple games, got the same error each time. As a bonus, I installed python3, which also didn’t change the outcome.

In general, precompiled Linux dynamic executables won’t work out of the box on NixOS. There are various reasons: no ld-linux at the de facto “standard” location, libraries not in the expected directory, etc.

If you need to run prebuilt executables, your easiest option is likely to rely on steam-run. A lighterweight (not requiring the Steam runtime) but more advanced option would be to use something like nix-ld.

The game isn’t from steam. Would that make a difference?

Yyep it works regardless if it’s steam or not, thank you!