Running AMD's Product Verification Tool (

AMD has a game rewards thing that lets you redeem a free game with a hardware purchase.

I assume to prevent botting and cheaters they require you to run a verification tool on your system, and nicely they have a linux version of said tool.

I can run tool with --keep and then patchelf`d the ./main binary that it generates but the tool fails to verify my hardware (perhaps it detects the tampering?)

Inside a buildFHSUserEnv it says it can’t find even with the library existing in the same directory as ./main, running the patched tool inside, it still fails to verify.

Any ideas?

Have you tried steam-run yet?

strace -f -e file ./main it to find out where it’s trying to look for libs.

Just a hunch but try LD_LIBRARY_PATH=. ./main.

steam-run uses Bubblewrap and breaks due to it trying to call sudo, and if I run steam-run with sudo it also fails to chdir due to permissions on the folder which doesn’t make sense for root.

Well you could try nix-ld (and possibly envfs), so you can run it unmodified outside any container tech.

What is it trying to run with sudo?

Another thing you could probably do is fire up a live ISO of some FHS distro, run the script, get your stuff and return to NixOS.

Running Pop_OS! using wine 8.0
all i had to do was:
go into terminal
went to my Downloads folder where the file was located
chmod +x

wine start

new window poped up and put in my sudo password
answered a few questions like Language and so on, put in my coupon code and it validated my Proccessor (the new product i bought)

it validated and is in my amdrewards account.