Screen locker crashing

Greetings everyone,

I’ve encountered an unusual error and am struggling to find a solution.

Additionally, I’ve noticed another peculiar issue: after performing a rebuild switch, I can’t run or open anything unless I reboot the system. For instance, when I click on Dolphin after a rebuild, a busy icon appears, and then nothing happens.

This might help:<name>.restartIfChanged = false;

I’ve been using this for polkit and systemd-logind services, not sure which one helped with this specific issue.

Observing the same message with plasma-mobile on lenovo-krane, I thought this was device-specific :sweat_smile:. I think I get this (edit: well, if it is the same error causing this) on wake, and not every time even. I’ll look up the logs later

Can you tell us more about your set-up and your device?

cheers, but have no idea what to use in place of name?

i’ve changed afew settings/services in my configs and its basically gone i just tried it on my Samsung laptop and received the same issue. i’m pre-amp-ting its a sddm issue

Whatever service you’d like to be not restarted on change.

As I said, I am using this line for “polkit” and “systemd-logind” services which I suspect can fix the issue you reported. But it is helpful for a lot of things: Some examples.