SD card reader "automount"

I have a Lexar LRw400 Sd card reader. In windows and all the Linux distros I’ve tried, slotting in an SD card performs automount just like a USB stick. But not in Nixos. My vagure memory suggestions that it might have worked under Nixos, but I’m not sure.

So the question is: Does it work just like a USB stick? - If so what is wrong???
If it is a different “device”, what steps do I need to enable? I can see the “reader” exists, but not any card slotted in.

Thanks for any pointers - fixing this will save me hours finding an alternative!

I have card adapters, and they work OK on KDE. One of them triggers the dmesg, the other does not.

What does your dmesg look like? What about lsusb?

My dmesg is as follows:

[344173.119107] usb 2-2.4.1: new SuperSpeed USB device number 4 using xhci_hcd
[344173.160694] usb 2-2.4.1: New USB device found, idVendor=05dc, idProduct=b054, bcdDevice=11.25
[344173.160699] usb 2-2.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[344173.160701] usb 2-2.4.1: Product: LRW400
[344173.160702] usb 2-2.4.1: Manufacturer: Lexar
[344173.160703] usb 2-2.4.1: SerialNumber: 201404089427
[344173.167137] usb-storage 2-2.4.1:1.0: USB Mass Storage device detected
[344173.170245] scsi host10: usb-storage 2-2.4.1:1.0
[344174.233363] scsi 10:0:0:0: Direct-Access     Lexar    Pro LRW400    -0 1.00 PQ: 0 ANSI: 6
[344174.236418] sd 10:0:0:0: [sdc] Media removed, stopped polling
[344174.236690] sd 10:0:0:0: [sdc] Attached SCSI removable disk
[344174.254542] scsi 10:0:0:1: Direct-Access     Lexar    Pro LRW400    -1 1.00 PQ: 0 ANSI: 6
[344174.259645] sd 10:0:0:1: [sdd] Media removed, stopped polling
[344174.259907] sd 10:0:0:1: [sdd] Attached SCSI removable disk

The above is the same when I plug in the reader either with or without an sd card inserted into the reader.


Bus 002 Device 004: ID 05dc:b054 Lexar Media, Inc. Dual-Slot Reader [LRW400U]

The reader light flashes as if accessing the sd card, then remains lit. I set automount removeable media that has never been mounted before in KDE - no difference.


I’ve a lexar LRW300U reader that works without issue on Gnome.

My lsusb and dmesg results in case it can help you.


Bus 002 Device 002: ID 05dc:b049 Lexar Media, Inc. USB_3_0 Reader


[    1.365532] usb 2-1: New USB device found, idVendor=05dc, idProduct=b049, bcdDevice= 0.01
[    1.365543] usb 2-1: New USB device strings: Mfr=3, Product=4, SerialNumber=5
[    1.365547] usb 2-1: Product: USB_3_0 Reader 
[    1.365551] usb 2-1: Manufacturer: Lexar 
[    1.365554] usb 2-1: SerialNumber: 000000038154


[    3.627996] scsi 2:0:0:0: Direct-Access     Lexar    CF  USB_3_0 Read LX01 PQ: 0 ANSI: 5
[    3.628627] scsi 2:0:0:1: Direct-Access     Lexar    SD  USB_3_0 Read LX01 PQ: 0 ANSI: 5

I’m having a bad week!

The SD card failed - it was working, and then I update my Nixos and it didn’t. I thought I’d checked with another card, but obviously didn’t.

Thanks too those who replied.