Setting up urxvt & i3

Hi all! So I finally got a linux nixos working. Now I’m trying to setup urxvt & also i3. I found this blog to guide me:…-i3-setup.html or https://webcache.googleusercontent.c…&ct=clnk&gl=ca

When I go to post a comment for support I find that it’s been removed. My error:

$ sudo nixos-rebuild switch --upgrade

unpacking channels…

building Nix…

building the system configuration…

trace: Default graphical session, ‘none’, not found.

Valid names for ‘services.xserver.displayManager.defaultSession’ are:




error: The option value services.xserver.displayManager.defaultSession' in /nix/var/nix/profiles/per-user/root/channels/nixos/nixos/modules/services/x11/display-managers/default.nix’ is not of type `session name’.

(use ‘–show-trace’ to show detailed location information)

Best regards,


Best regards

I think the post is missing

  services.xserver.windowManager.default = "i3";

next to

  services.xserver.desktopManager.default = "none";

which is required since

Actually, the two options were turned into one:

  services.xserver.displayManager.defaultSession = "none+i3";

We might want to improve the error message when only desktopManager.default is set, though.


So you’re saying that I should add those to configuration.nix and leave default.nix alone?

Best regards,

That took care of that error just to get another error.

$ sudo nixos-rebuild switch --upgrade
unpacking channels...
created 2 symlinks in user environment
building Nix...
building the system configuration...
error: The option `services.xserver.displayManager.job.execCmd' has conflicting definitions, in `/nix/var/nix/profiles/per-user/root/channels/nixos/nixos/modules/services/x11/display-managers/sddm.nix' and `/nix/var/nix/profiles/per-user/root/channels/nixos/nixos/modules/services/x11/display-managers/lightdm.nix'.
(use '--show-trace' to show detailed location information)

but /nix/var/nix/profiles/per-user/root/channels/nixos/nixos/modules/services/x11/display-managers/sddm.nix has no mention of services.xserver.displayManager.job.execCmd so where’s the conflict?

Best regards,

1 Like

Do uou perhaps have both services.xserver.displayManager.sddm.enable = true; and services.xserver.displayManager.lightdm.enable = true;? You can only have one display manager, though I would expect a better error message there as well. Could you please report an issue against nixpkgs that display manager conflict needs a better error message?

So i tried to reboot after these changes & it gives me the login prompt where I type

$ startx

this gives me 3 i3 windows with the wrong colors (white background, black font instead of black background, white font)

so I double check everything & it looks fine but I added programs listed in Getting started with the i3 tiling window manager - Fedora Magazine (except for i3status & i3lock I replaced those with i3status-rust & i3lock-color) thinking maybe that would help but it didn’t.

NB I added
` services.gnome3.gnome-keyring.enable = true;
services.gnome3.seahorse.enable = true; = true;`

to configuration.nix
& it returns
` services.gnome3.gnome-keyring.enable = true;
services.gnome3.seahorse.enable = true; = true;`
Honestly I prefer sddm but I’ll take what I can get

Best regards,