[SOLVED] Haskell-language-server (aarch64)

I’m using a pretty recent haskell-updates:

bash-4.4$ echo $NIX_PATH_HASKELL                nix-on-droid=https://github.com/t184256/nix-on-droid/archive/5c838f508bfc71a5599522b6f181d9a9324506e2.tar.gz:home-manager=https://github.com/nix-community/home-manager/archive/9ad0024d4d292c628d4c9a50c2347f23418d7000.tar.gz:nixpkgs=https://github.com/NixOS/nixpkgs/archive/f618f8ba385527b09fb5ba4e914de9667ddc55cf.tar.gz

When trying to build hls with either ghc version I’m getting errors as depicted below.

Is there a chance building it still (nix-shell works)

nix-repl> :b haskell.lib.compose.dontCheck (haskell.lib.compose.markUnbroken haskell.packages.ghc884.haskell-language-server)

also tried

nix-repl> :b haskell.lib.compose.dontCheck (haskell.lib.compose.markUnbroken haskell.packages.ghc865Binary.haskell-language-server)

and

nix-repl> :b haskell.lib.compose.dontCheck (haskell.lib.compose.markUnbroken haskell.packages.ghc901.haskell-language-server)

There is a file in Nixpkgs defining a Hydra jobset for Haskell stuff in the haskell-updates branch:

If you search through this file, you will see that haskell-language-server is built on multiple platforms with multiple versions of GHC.

Here’s the corresponding jobset on Hydra:

https://hydra.nixos.org/jobset/nixpkgs/haskell-updates

If you go to the Jobs tab and search for haskell-language-server, you can see the recent build results.

It looks like there were a couple days when haskell-language-server wasn’t building recently, but the latest commit appears to be all building:

In general, if you are depending on your haskell packages building correctly, I’d highly recommend pinning against master or one of the channels. haskell-updates only gets merged into master when most Haskell things are building correctly, but haskell-updates itself may be completely broken on any given commit.

If you do absolutely need to use haskell-updates for some reason, I’d recommend you keep an eye on the haskell-updates jobset on Hydra, or GitHub - cdepillabout/nix-haskell-updates-status: Automatically-updated Hydra status of the `haskell-updates` branch in Nixpkgs.

1 Like

Solved my question. Thank you.

Hosted by Flying Circus.