SOLVED: Odd mouse capture/warping issue in World of Warcraft on NixOS specficially

Hey there! New to NixOS but not new to Linux. My last distro went bang yesterday, so I took the hint and finally switched to Nix. Everything’s great aside from one very specific issue I’m having a nightmare tracking down.

When playing World of Warcraft, camera turning is performed by clicking, holding, and dragging the mouse to pull it around. This hides the cursor, and once the mouse button is released the cursor should reappear back in the place it originally disappeared after the initial click.

It does not do that - instead, the cursor continues moving while hidden, appearing where it would be if the mouse movements were not suppressed. Not only is this disorienting, it means that the camera cannot rotate further once the cursor hits the edge of the screen, and it causes the camera to snap wildly on occasion.

After some initial googling, I thought it was this issue, reported 3 years ago as an XWayland bug. Odd that it would be such an old resolved issue I thought, but I tried to test under X11 where the issue is supposedly not present - same issue.

For completeness, I’m running a 3080 and 7950X3D, I started out on a stable branch, but have moved to unstable for a few packages I wanted - this doesn’t seem to be the cause of my issue. I have tried various permutations of:

  • DE (X11 and Wayland): KDE, Gnome, XFCE, Hyprland
  • Nvidia Driver
  • WoW install/runner: Bottles, Lutris, Steam - variety of Wine-GE, Proton, Proton-GE, Soda, Caffe etc.
  • Wine environment variables: Mouse capture, fullscreen capture, windowed, virtual desktop, mouse warp override, mouse click delay, and more I forgot to note down
  • Kernels

The only constant between these permutations that I can think of is NixOS - this setup worked fine on Arch, so I must be missing something about how NixOS (or my config thereof) handles mouse capture/warping/etc.

I’ve seen other mouse bugs in other games in my testing, but all of those were solved by environment variables, newer drivers/runners, or a different DE. World of Warcraft is unique in consistently showing the same mouse issue across all permutations.

What might I be missing here?
Thanks for reading!

Edit: SOLVED: The issue was that I was running the native version of Bottles/Steam/Lutris etc. Running under flatpak bottles on Plasma 6 Wayland with the following WoW CVAR set to 0 - SET MouseNoRepositioning "0" - solved the issue. It is unclear why this issue presents only on the native package; it may have something to do with Nvidia, as one commenter on Reddit did not have this issue on native with a Radeon card.

You are the man! I created an account just to thank you for helping me solve this issue. I literally installed Windows 11 yesterday, and I was very close to giving up on Linux (temporarily) until the problem was solved.

I actually used the native clients specifically to avoid using flatpaks. It’s a shame that the only fix is going back to using them again.

Edit: I forgot to confirm that this problem indeed only affects nvidia systems. My previous AMD one never had any of these issues.

Glad to hear this post could help!

I also wanted to use the native clients and avoid flatpaks - it seems to clash with the idea of having the whole OS in a config file, so it’s a little frustrating to have to move back to them.

I’d be very intrigued to know if anyone has any clue as to why this occurs with Nvidia cards and NixOS native installs specifically.