[SOLVED] Problems installing from 21.05 image

Went to put nixos on a laptop since I run it for work and everything is great. This is my first experience with 21.05.

Encountered several problems w/ the live images and gave up.

w/ gnome image

  • Firefox worked fine when not connected to wifi. When connected to wifi it would immediately close w/ message “exiting due to channel error” & “bus error (core dumped)”. I troubleshooted by running firefox w/o extensions (safe-mode), checking dbus, and running w/ dbus-launch. It would immediately crash no matter what. This prevented me from following the docs.
  • gparted failed to start
  • the terminal was not fully interactive and backspace keypresses would be rendered as spaces. It was like the system didn’t have any terminfo on hand.
  • xterm failed to start also.

w/ kde image

  • Firefox would stay open slightly longer, but would close anyway after about a few minutes or less. I do not know if the two issues were related.
  • the terminal failed to start
  • xterm failed to start, also
  • during one attempt, i used the kde settings to change the timezone, and any keyboard input on the status bar (eg, entering a wifi password or searching for an application) would crash kde.

It’s not pertinent to nixos, but I also want to report that my overall experience tonight was just poor. I started with Pop!OS, which had a ‘shakey’ screen issue I was unable to resolve after an hour … but it did install. Clear Linux had the same display issue and failed to install without presenting any helpful troubleshooting tip. I took my frustration out on a disposable household item.

What laptop do you have?

I tested firefox, gparted, and xterm on nixos-21.05 and they all work fine on my laptop, and desktop… not to mention you’ve had issues with other distros, leads me to believe that something else is at play

It’s an MSI Stealth laptop from 2016. Amazon.com: MSI GS72 Stealth-042 17.3" SLIM GAMING LAPTOP NOTEBOOK Geforce GTX 965M i7-6700HQ 16GB 128GB SSD + 1TB WIN 10: Computers & Accessories

Also, I can provide more information about the gparted & xterm issues later today.

@jonringer not sure what was going on last night, but I tried again about an hour ago and everything worked flawlessly w/ the gnome image. It installed & nixos 21.05 runs great on my old laptop.

2 Likes