Something is wrong with my system update, stuck in the past?

These last days, I’ve had an issue preventing me from building/updating my NixOS system due to a build failure from opencolorio (x86_64, unstable branch)

The issue is fixed and the dependency has been patched. 1 day later, the pull request gets merged from master into nixos-unstable, but I still get the same build errors when updating.

Check the above issue’s last comments. Apparently opencolorio and blender build just fine, but I still get the same build failure errors when trying to rebuild my system, as if I was stuck in the past.

What’s going on?

I ran both nixos-rebuild switch and nixos-rebuild switch --upgrade as root

1 Like

What’s the exact commit your system is building from?

Where do I see this?
This is the channel I build from

I use the same channel. After sudo nix-channel --update I was able to rebuild. Maybe nixos-rebuild --upgrade doesn’t update the channel. What is the output of nix-instantiate --eval -E '(import <nixpkgs> {}).lib.version'?

1 Like

I also ran nix-channel --update as root and it didn’t work back then. I just ran it again and it actually updated my channel this time weirdly. The problem is fixed and my system builds successfully


No idea, I don’t use channels (use flakes instead), presumably there’s a way to get the metadata about a channel. But if you don’t know what commit it’s building against, it’s not really possible to say what’s happening.