Stage 1 Boot Failed for NixOS

I was trying to replicate my system to another laptop so I installed the Plasma ISO.

Describing the bug

When booting using a USB drive, NixOS boot does not get past stage 1 of its boot to then go the stage 2, later land at a graphical installer when you can install NixOS.

Steps to reproduce

  1. You can click here if you want to install the ISO and run it in a VM or something.
  2. Burn into onto a USB stick how ever you like or use a VM.
  3. Wait

Expected Behavior

past stage 1 and stage 2 boot process and land at graphical installer.

Screenshot of Bug

I have tried formatting my USB stick and burning the ISO on it again and again hopes of installing. Any help would be highly appreciated.

1 Like

Most systems can not be replicated without some changes to the config, but you didn’t give enough information as to whether you are using your configuration.nix completely unmodified or whether you generated a unique hardware-configuration.nix. Do you have a link to your configuration perhaps, or could you at least give a bit more detail?

Sorry, for the lack of detail on my end.

I have resolved this issue by booting from another USB, somehow the USB stick I was using to boot into the NixOS installer was corrupt. so I tried using another one and it worked.

I really appreciate your help though.

1 Like

Hi. I almost gave up after seeing that you had to use another flash drive which does not seem like a solution and still I wanted to try and make new install on my USB. But this time I decided to use different file system FAT32 ( using latest rufus 4.3) . THen i noticed that these installations perhaps are persistent , whcih means that your data that you download or install is stored on the flash drive . So I set up the flash drive this time with persistent mode( persistent partition size 8GB for example) and it worked… So persistent mode using rufus and FAT32 file system. I had the same issue with kali linux when updating the system with apt update. It said at one point that it does not have space because I did not choose the size of the persistent partition.
Nix OS interface is great. I’ll gladly explore it further
Hope this helps other people that might face the same issue

1 Like