Start cage with WLR_LIBINPUT_NO_DEVICES=1 set (no keyboard mouse connected on pi4b)

Hi, im using cage lately on my raspberrypi4b and it works like a charm, starts automatically after booting and displays firefox with the url set, until i realised without a connected keyboard or mouse it results in a black screen as described in

…im having difficulties integrating WLR_LIBINPUT_NO_DEVICES=1 to my setup, would anyone be so kind and help me out on how to do this?
my current configuration looks like this;

environment.systemPackages = with pkgs; [ cage (…) firefox ];
services.cage = {
enable = true;
user = “user1”;
program = “${pkgs.firefox}/bin/firefox -kiosk -private-window”;
thanks in advance for your help!

after some classic trial and error sessions i solved it;
inside the config;

wlrLibinputNoDevices = “1”;


services.cage = {

environment = {
WLR_LIBINPUT_NO_DEVICES = wlrLibinputNoDevices;