Steam Blank Screen

Has anyone else noticed a problem where Steam just shows a blank screen?

Small mode would work but games wouldn’t launch and big mode would only show the top bar with “Store Library …” and the bottom bar with “Add new game Downloads …”.

I say would because I tried deleting ~/.local/share/Steam to get Steam to reinstall, and now I can’t login because the login screen is blank.

I’ve noticed this repeating error when I run Steam in the terminal:

dirname: /home/aerits/.local/share/Steam/ubuntu12_32/steam-runtime/lib/x86_64-linux-gnu/ version `ATTR_1.3' not found (required by dirname)

I’m not sure how to fix this, and with a little googling I haven’t been able to find anyone else experiencing this error. I’m not sure if thats because its a NixOS problem or just a Linux problem in general.

dirname is a command that just returns the name of the directory a file is in, how is this even erroring?

Another recurring error is this:

src/steamexe/main.cpp (255) : Assertion Failed: reaping pid: 408170 -- steamwebhelper.

I observed exactly the same as you. It might be this issue on the steam-for-linux repo, though this is with ‘beta’ I think: [Steam UI] Unresponsive and black/blank screen on the new UI · Issue #9386 · ValveSoftware/steam-for-linux · GitHub

However, this was about a week ago. I just updated nixpkgs (I use nixos-unstable channel) and I was just able to login again and properly see the library etc. So looks like whatever the issue was, it is fixed on my system.

I’ve had this happen to me recently, actually before the UI change.

Usually it was fixed if I quit Steam (fully quit, not just the main window). Sometimes I had to reboot to fix it, however.

Not sure if it’s still happening because it was intermittent, and I haven’t had it happen in the new UI myself.