Steam client stuck on "loading user data"

I updated my config earlier today and Steam stopped working. When I try to open it, it gets stuck on the “Loading User Data” screen.

So far, I have tried deleting my Steam data, but after I logged back in, nothing changed. It also works fine when I revert to a previous generation. I assume it’s a problem with the client rather than user data.

My config: GitHub - Anomalocaridid/dotfiles: My personal dotfiles for NixOS

Also, I already checked if using the nix-gaming flake in my config caused it, but it looks like the problem persists even when I remove it.

I had the same issue, the problem turned out to be that Hyprland (or wlroots) isn’t compatible with the nixos graphics driver (at least that’s my best guess).
I fixed that by making Hyprland follow my nixpkgs, and picked the latest version that actually built with it, since the latest one has trouble compiling with dependencies from 23.05 that I was unable to work around.


I was reluctant to have to compile Hyprland myself, so I tried to instead pin it to the last known working revision of the Hyprland flake (obtained via the commit message generated by nix flake update). Unfortunately, while it installed successfully, it did not fix my problem with Steam, even after rebooting.

However, on further investigation, I found that Hyprland had recently upstreamed their NixOS module. The same appears to be true for the Home Manager module. So I just switched from the flake to the nixpkgs version and that fixed the problem for me.