Steam games unable to load

I installed Steam (nativeOnly = true) and I’m trying to run Windows games via Steam Play, I tried two so far and both didn’t even start, with roughly the same error (line 14). I tried a Linux supported game and works fine.

I tried changing the LD_LIBRARY_PATH variable by running Steam like this

LD_LIBRARY_PATH=$(nix eval --raw steam

and also manually changing the LD_LIBRARY_PATH before launching steam

$ export LD_LIBRARY_PATH=$(nix eval --raw
$ steam

Just to be sure

$ cd $(nix eval --raw
$ ls | grep # EXISTS

So far nothing worked and nothing changed.
This is my NixOS configuration

Why games are not seeing the library, am I setting the LD_LIBRARY_PATH wrong? Please help, thanks.


Have you tried using the penultimate version of Proton instead of the latest?

Proton 5.0 works, any idea how to make the latest version (5.13) work?


you may want to look at:


to see if it’s doing anything odd. For example, zachtronics games will unset LD_LIBRARY_PATH.

Also, can you do nix-shell -p nix-info --run "nix-info", so it can be better reproduced.

This doesn’t work due to buildFHSUserEnv

$ SOMETHING=HI steam-run echo $SOMETHING

Thank you for your reply! This is the output of nix-shell -p nix-info --run "nix-info"

system: "x86_64-linux",
multi-user?: yes,
version: nix-env (Nix) 2.3.6,
nixpkgs: /nix/var/nix/profiles/per-user/root/channels/nixos

I took a look at pressure-vessel-adverb, but it’s in binary and I don’t understand much, is there anything else I can do?


This looks like the issue described in this github issue.

Currently it seems pressure-vessel needs adaptation and maybe libexpat added to the env.