Steam-run doesn't find libssl

I installed Stardew Valley using minigalaxy and used to run it using steam-run command, but after upgrading the OS from 22.11 to 23.05 it is no longer working.

Running Stardew Valley
NoFpsCap: This feature is not available
setGameMode( 'titleScreenGameMode (0)' )
loadPreferences(); begin - languageCode=
No usable version of libssl was found
./StardewValley: line 27:  8656 Aborted                 (core dumped) ./"Stardew Valley" $@

Since this one, I guess:

Any solution? Maybe not using steam-run?
I tried wine, but I get missing dll errors
How can I use openssl 1.1 in steam-run?

The list of the packages is overridable. And steam-run in particular just has a default set of packages that’s considered useful with steam and its games, but you can choose whatever (though I don’t recall how exactly).

This worked, but it’s temporary, since the support ends on September 11.

(steam.override { extraPkgs = pkgs: [ openssl_1_1 ]; }).run

nixpkgs.config.permittedInsecurePackages = [ "openssl-1.1.1u" ];