Stuck with a failing lightdm


#1

Hi,

I have just installed nixos on a brand new laptop following these directions, which are specific to my hardware. Everything seems to have gone smoothly, except for the Lightdm display manager, which doesn’t load (I have a back screen with a blinking prompt). Unfortunately, I have set displayManager.autorun = true;and I cannot switch to a console by hitting CTRL + ALT + 1. Can you recommend any way I get a back on a console and disable the auto-login?

Note: unfortunately both the configuration I see displayed in the bootloader have autologin enabled, so reverting to a previous version doesn’t seem to be an option


#2

Do you hit CTRL ALT 1 or CTRL ALT F1-F6?

First suggestion is to boot from USB. Another option is if you’re lucky to use GRUB. Modify kernel boot params during boot - set runlevel 3 and boot into text-mode.


#3

To be more specific about booting into text mode, in GRUB and systemd-boot you can edit the kernel command-line by pressing e on the menu entry. If you add systemd.unit=multi-user.target, it will not start the display manager, allowing you to log in to a text console.


#4

Thanks for the tip @danbst @lheckemann lheckemann!
somehow the problem disappeared after two reboots, when I was prompted for the normal user login and I had the chance to set displayManager.autorun to false. However, I am now struggling setting up XWindows. Will post the details shortly!