Swaylock won't unlock

I am running hyperland on unstable, and have installed swaylock. When I try to unlock swaylock, it doesn’t accept my password. Does anyone know how to get it working?

This should do the trick:

security.pam.swaylock = {};

(in configuration.nix)


Thanks. That helped. It’s actually:

security.pam.services.swaylock = {};

But, I have fprintd enabled, and the above only allows me to unlock with a fingerprint, and not my password. Any thoughts?

fprintd will try and authenticate you first if it’s enabled. Only if it fails will it fall through to other methods.

You’ll either need to wait for the failure or disable it for swaylock completely like so:

security.pam.services.swaylock.fprintAuth = false;
1 Like

Awesome. Thanks for the clarification!