`tailscale ssh` destroys `nix copy`

If I’m executing nix copy --to ssh:tornax@laptop nixpkgs#hello then I’m getting the following error message:

/nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 20: warning: setlocale: LC_NUMERIC: cannot change locale (de_DE.UTF-8): No such file or directory
/nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 23: warning: setlocale: LC_TIME: cannot change locale (de_DE.UTF-8): No such file or directory
/nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 20: warning: setlocale: LC_NUMERIC: cannot change locale (de_DE.UTF-8): No such file or directory
/nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 23: warning: setlocale: LC_TIME: cannot change locale (de_DE.UTF-8): No such file or directory
error: 'nix-store --serve' protocol mismatch from 'tornax@laptop', got '/nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 20: warning: setlocale: LC_NUMERIC: cannot change locale (de_DE.UTF-8): No such file or directory
       /nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 23: warning: setlocale: LC_TIME: cannot change locale (de_DE.UTF-8): No such file or directory
       /nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 20: warning: setlocale: LC_NUMERIC: cannot change locale (de_DE.UTF-8)
       /nix/store/3h8pyqvrq9l4m2pz95rshnrd79508m7l-set-environment: line 23: warning: setlocale: LC_TIME: cannot change locale (de_DE.UTF-8)
       �RT'

I could trace down the culprit and it’s tailscale’s ssh. nix copy works if I disable tailscale’s ssh.
Now I’m wondering why this happens. Does anyone know how to get nix copy to work even with tailscale’s ssh enabled?

Perhaps @Within has an idea.

1 Like