Tell GTK apps to use Dark Mode (in Plasma)

Hi folks,

Could you please tell me if there is a way to “ask” GTK apps running on KDE Plasma to use dark mode?

I experience funny “issue” where my plasma is completely dark but one or two apps that are not Qt (for example Meld) are very painful to use since they’re completely white.


There should be a setting to change your GTK theme in Plasma settings under Appearance → Application Style. Here you can set GTK apps to use Breeze and it should follow your Plasma theme.

I was just messing around with this today, and I’m not 100% confident that this has much effect, but if you use home-manager, you might try putting this in your hm config

  gtk = {
    enable = true;
    theme = {
      name = "Breeze-Dark";
      package = pkgs.libsForQt5.breeze-gtk;

1 Like

GTK should in principle pick up the light/dark color scheme change and then switch as well, but there are a number of issues with that - this is not nixos specific but indeed plasma issues.

After switching from light to dark, can you try restarting these user services:
xdg-desktop-portal and plasma-xdg-desktop-portal-kde

Thank you all. The setting in Plasma settings solved it ;-). Apologizes for a question that didn’t have NixOS answer ;-). Thank you ALL!