Trouble booting NixOS. Is there a workaround?

Hi there NixOS community,

I’ve recently picked up on the hype around Nix and wanted to try out the operating system for myself, as I have only heard good about it. However I have run into the problem that I cannot boot the os from my USB, every time I try I am thrown into the Grub shell. There I can see my USB stick and I can see some of the files, including a couple of efis but I have no clue how to proceed, or why the problem even occurs in the first place. I have created a SuperUser post about this issue, but it seemed like a good idea to also post about this here. If anyone has so much as an idea how to handle a situation like this, please write me, anything could help.

best regards, CCI

Are you sure you’re actually booting from the USB and not some grub that’s already installed on the system?

Yes pretty sure. the medium is labeled with the name of the company that made the USB + the word USB as well. What I can do right now is switch pc and walk through the entire process in detail

be right back


I’ve now put in the USB device and started the Pc into the boot menu (F9 for me). I am now looking at a screen with five options to boot from:

  • UEFI - SMI Technology Intenso (this is the USB I am pretty sure)
  • UEFI - SK hynix PC801 (don’t know about this one, but Im guessing its the harddrive)
  • two options for network boot and the “Boot from file option”

I’m going for the first:
this is already where I am looking at the grub shell (the image in the superuser post) and I can do little more then to shut down my device and restart into windows

PS: I really want this problem resolved so ask me whatever you need to know and you will get a detailed answer.

Yep, sounds like you’re at least booting the USB in UEFI mode, and your firmware isn’t doing anything wonky.

At that point, sounds like the USB is just broken. How exactly did you burn the image to the USB? Did you check the checksum of the image?

I used Rufus ( the settings are explained in the SuperUser post) to flash the USB, and I have tried with a different usb but got the same result. I did not check the checksum of the image but I can try to do that!

EDIT: I tried booting Ubuntu to see if it was just something with my setup, but that worked fine…

Update: the checksum is correct for the iso I downloaded but I will flash the usb again

Update: nope same result, this time the iso definitely had the correct checksum

Rufus is cool, but iirc it tries to be smart. It’s likely screwing this up.

The NixOS manual recommends etcher.

1 Like

I flashed it again using the “Disk” tool of ubuntu, and it didn’t work either so rufus isn’t the problem it seems…
I will try etcher though!

etcher worked!!! now I can dive in, thank you!

1 Like