Trouble starting game through Steam

I’m having issues starting a game through Steam. The error I get is:

ERROR: object '/home/games/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.

running ldd on the executable that starts the game suggests that some libraries are missing (I’ve omitted the ones that were found): => not found => not found => not found => not found => not found => not found => not found

So I created ~/.config/nixpkgs/overlays/steam.nix to try to install the libraries:

self: super:
  steam = super.steam.override {
    extraPkgs = pkgs: [ self.xlibs.libX11
                        self.utillinux ];

However the game still doesn’t start and the error message is the same. What is the next step(s) to take?

This is often caused by games that set LD_LIBRARY_PATH without appending to it instead. What game is it?

The game is Europa Universalist IV.

It was working last week but then they updated the game to 64-bit from 32 and now it crashes on launch.

I can get it to run outside steam using “steam-run”, though.

I’ve been having issues with the same game. The update which switched from 32 to 64 bit also included a new launcher program, which may also be the cause of the issue. I’m planning to spend some time this weekend digging into it.

Awesome. I’m busy through at least the first, but please do share any progress!

@Taneb any luck getting EU4 to start through Steam?

you may also want to try using the steam-run command. But I will see if I can’t get it working when I get home, as I also play EU4 :slight_smile:

Thanks. I got it working through steam-run once but not since then.

Good luck, and let me know if you make progress!

@jonringer Any luck? I was hoping to try the new Manchu patch this weekend :slight_smile:

sorry, been busy with oxygen not included :). Trying it out now

1 Like

A little hacky, but it works:

$ nix-shell -p steam-run-native --run "steam-run ~/.local/share/Steam/steamapps/common/Europa\ Universalis\ IV/eu4"
1 Like

I still get “error while loading shared libraries: wrong ELF class: ELFCLASS32”

make sure you got

  # for steam
  hardware.opengl.driSupport32Bit = true;

in your configuration.nix

Thanks. Yes, I have that.

you may want to try again, pretty sure incidentally fixed all the paradox launchers.

At the very least, it starts without any additional effort.


Awesome, thanks for letting me know!

I had to uninstall then reinstall EU4 and steam and delete all the cached files but appears to be working flawlessly now. :slight_smile:

1 Like

Since my previous link just got 50 hits, this PR: should have fixed the CK III launcher, and by extension, the other paradox launchers as well

1 Like