Trusted-users is ignored in .config/nix/nix.conf?

I’m trying to use nix in my arch.
So I installed nix using pacman and tried to use substituters in my nix.conf.
This is my nix.conf:

substituters = https://mirrors.ustc.edu.cn/nix-channels/store https://mirrors.tuna.tsinghua.edu.cn/nix-channels/store https://cache.nixos.org/
experimental-features = nix-command flakes
max-jobs = auto
trusted-users = gus

As you can see,I’ve added my user name to trusted-users but warnings keep going:

❯ nix run nixpkgs#cowsay some of you
warning: ignoring untrusted substituter 'https://mirrors.ustc.edu.cn/nix-channels/store', you are not a tr
usted user.
Run `man nix.conf` for more information on the `substituters` configuration option.
warning: ignoring untrusted substituter 'https://mirrors.tuna.tsinghua.edu.cn/nix-channels/store', you are
 not a trusted user.
Run `man nix.conf` for more information on the `substituters` configuration option.
warning: error: download of 'https://channels.nixos.org/flake-registry.json' was interrupted; using cached
 version
error: interrupted by the user

I’ve restarted nix-daemon btw.

I end up solving this by moving trusted-users to /etc/nix/nix.conf.